AWS service problem impact on Prendio application

Incident Report for Prendio Procure

Resolved

The application is stable and AWS has determined their service issues to be resolved. The Prendio team will review the situation for possible future infrastructure changes that can help mitigate the impact of similar situations.
Posted Oct 20, 2025 - 19:21 EDT

Monitoring

The Prendio team will continue to monitor for recurring issues and updates from the AWS team about their service issues from today.
Posted Oct 20, 2025 - 17:22 EDT

Update

The Prendio application is operational again. This includes the Analysis tab, which was impacted earlier in the day.
Posted Oct 20, 2025 - 17:22 EDT

Update

The Prendio application is still experiencing periods of slow responsiveness or timeouts. Amazon continues to work on corrective action - We are continuing to monitor their progress and any changes to availability for the service impacting the Prendio application.

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 14:44 EDT

Update

The Prendio team confirmed that the current access and responsiveness problem is related to issues with the Amazon CloudFront service. We are monitoring the related services and the corrective actions being worked on by AWS: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:30 EDT

Update

At approximately 11:58 AM EDT, the Prendio application started experiencing behaviors ranging from slow responsiveness to the display of the application being down for maintenance. The Prendio team is investigating to see if the behavior is related to the AWS service problems or a separate problem.
Posted Oct 20, 2025 - 11:59 EDT

Investigating

The Prendio team is monitoring the October 20, 2025 service problems with Amazon Web Services (AWS) for possible impacts on the Prendio application and related services. Among the known impacts:

- Users might not be able to access the Analysis tab depending on their geographic location

- Prendio and BioProcure support teams are experiencing delays in accessing attachments to emails/tickets, due to the AWS service problem's impact on the application used for ticket management

More information from Amazon regarding the service issues can be found in their Service Health Dashboard: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 09:30 EDT
This incident affected: Prendio Procure App.