ERP sync and mapping problems

Incident Report for Prendio Procure

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 14:06 EDT

Identified

The Prendio team is working to resolve a problem that results in windows for Supplier ERP Sync or Let's Push to hang. The problem can also result in supplier mapping changes not saving properly or being delayed.
Posted Sep 08, 2026 - 13:00 EDT
This incident affected: ERP Integrations.