Prendio non-responsive, showing maintenance page

Incident Report for Prendio Procure

Resolved

This incident has been resolved.
Posted Sep 23, 2026 - 17:20 EDT

Update

The trigger for the server responsiveness issue was identified, and steps will be taken to prevent the problem from happening again.
Posted Sep 23, 2026 - 17:20 EDT

Monitoring

The Prendio application is accessible again. The Prendio team is analyzing the situation and monitoring the app for continuing availability.
Posted Sep 23, 2026 - 14:12 EDT

Investigating

We are investigating an issue related to the Prendio app being non-response or showing a maintenance page.
Posted Sep 23, 2026 - 14:00 EDT
This incident affected: Prendio Procure App.